Explorer Instability After Horizon Upgrade

Incident Report for The Graph

Resolved

This incident has been resolved.
Posted Dec 19, 2025 - 19:18 UTC

Update

Delays in retrieving delegation metrics were identified due to query complexity and gateway-related issues.
The product team is actively working on a fix.
Posted Dec 17, 2025 - 18:18 UTC

Identified

Some users are experiencing issues when managing and viewing delegations and related metrics.
Our product team is actively investigating and working on a fix.
Posted Dec 17, 2025 - 17:57 UTC
This incident affected: Network - Explorer and Network - Subgraph Studio.