eth_calls to BSC are non deterministic
Incident Report for The Graph
Resolved
This incident has been resolved.
Posted Sep 18, 2021 - 08:06 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2021 - 15:22 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 09, 2021 - 00:33 UTC
Investigating
We are currently observing problems with eth_calls to the BSC chain. Technically, there is a problem with EIP-1898 support. That means that eth_calls are made by blockNumber and not by blockHash which can lead to unexpected results during reorgs.
Posted Aug 27, 2021 - 13:38 UTC
This incident affected: Hosted Service - Indexing (BSC).