Explorer Instability After Horizon Upgrade

Incident Report for The Graph

Resolved

This incident has been resolved.
Posted Dec 13, 2025 - 12:47 UTC

Update

Some users are experiencing issues when managing delegations (delegating, undelegating, withdrawing, etc.).
Our product team is actively investigating and working on a fix.
Posted Dec 12, 2025 - 23:26 UTC

Monitoring

Following recent contract upgrades, some historical charts and delegation stats may be incomplete or out of date.
Posted Dec 10, 2025 - 00:54 UTC

Identified

We’re currently experiencing instability with the Explorer following today’s Horizon upgrade.
The team has identified the underlying issue and is pushing a fix now.
Posted Dec 10, 2025 - 00:53 UTC
This incident affected: Network - Explorer and Network - Subgraph Studio.