Subgraphs with errors do not switch their status to failed
Incident Report for The Graph
Resolved
This incident has been resolved.
Posted Nov 10, 2021 - 18:44 UTC
Monitoring
The fix has been merged. It is in production. One note...if people want to query failed subgraphs, they'll have to add a subgraphError: allow to their queries as described here: https://github.com/graphprotocol/graph-node/issues/2885#issuecomment-947841678. Newly deployed subgraphs are working as intended. Previously failed subgraphs still might be affected and we are monitoring.
Posted Oct 21, 2021 - 17:28 UTC
Update
We are continuing to investigate this issue.
Posted Oct 18, 2021 - 07:43 UTC
Update
After troubleshooting, this appears to be a side effect of the PoI for a failed subgraph’s PR. We are working on the fix.
Posted Oct 15, 2021 - 18:00 UTC
Investigating
We are seeing notices for a small amount of subgraphs that return "message": "indexing_error." Affected subgraph otherwise index normally, as opposed to failing. These subgraphs are marked "health": "unhealthy" in our internal health-query.
Posted Oct 15, 2021 - 16:00 UTC
This incident affected: Hosted Service - Subgraph Health.