Back

Etherlink Sepolia Lagging Behind

January 19, 2026 at 04:46 PM UTC Resolved after 9d

Updates

Resolved

We are currently investigating this issue.

January 28, 2026 at 06:59 PM UTC
Investigating

We are currently investigating this issue.

January 19, 2026 at 04:46 PM UTC